SEV2 Reason for Visit and Appointment note fields not displaying text entered until second click of Pencil Icon

Incident Report for Vetspire Status Page

Update

Our Development team is actively working on implementing a fix for this issue. We appreciate your patience and will keep you informed with updates as progress is made.
Posted Jun 25, 2025 - 15:12 EDT

Identified

Our Developers have identified the cause and are working on a fix.
Posted Jun 24, 2025 - 08:07 EDT

Investigating

We are aware of an issue with the Reason for Visit and Appointment note fields not displaying text entered until second click of Pencil Icon.
Posted Jun 23, 2025 - 13:27 EDT
This incident affects: Vetspire UI (Web APP).