Vetspire is slow or not loading.
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved.
Posted Dec 07, 2022 - 16:49 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 07, 2022 - 16:45 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 07, 2022 - 16:44 EST
Investigating
Vetspire Support is investigating the inability to search products.
Posted Dec 07, 2022 - 16:42 EST
This incident affected: Vetspire UI (Web APP).