Partial IDEXX Outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 16:28 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2026 - 14:09 EST

Investigating

We are aware that IDEXX is investigating a potential issue affecting lab ordering and lab result generation. Please refer to the IDEXX VetConnect Portal for the most up-to-date information.
Posted Mar 07, 2026 - 11:41 EST
This incident affected: Labs (Third-Party Integrations) (IDEXX VetConnectPlus & In-House Labs).