SEV-1 Unable to load certain invoices

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Oct 22, 2024 - 16:42 EDT

Investigating

We are investigating an issue where certain invoices are not loading in the UI.
Posted Oct 22, 2024 - 15:45 EDT
This incident affected: Vetspire UI (Web APP).