SEV 2-Vet & Tech Names Not Auto-Populating Under Encounter Footer
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved.
Posted Jan 31, 2025 - 07:54 EST
Investigating
We are currently investigating this issue.
Posted Jan 30, 2025 - 10:12 EST
This incident affected: Vetspire UI (Web APP).