We're currently seeing a partial outage impacting Vetspire Support, which runs on Freshdesk and Microsoft services.

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 21:17 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 16, 2025 - 14:42 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 14:42 EDT

Identified

Good news — the issue appears to be identified and under control by our service providers (Freshdesk + Microsoft).
Here’s what we’re seeing:
• The backlog of incoming and outgoing messages is actively shrinking
• Response times are steadily improving
• No action needed — previously delayed messages are processing automatically
We’ll continue to monitor and will post a final update once everything is fully resolved.
Thanks again for your patience
Posted Jul 16, 2025 - 12:12 EDT

Investigating

Here’s what we know so far:
• Some users are experiencing issues with ticket submissions and email replies
• Access to the support portal may be intermittent or unavailable
• We're actively working to understand the impact.
What this means for you:
• There may be delays in response times or missing tickets
We’ll keep you updated every 60-90 minutes (or sooner if there’s progress). Appreciate your patience while we work through this!
Posted Jul 16, 2025 - 10:24 EDT
This incident affected: Vetspire Support - Using Third-Party Integrations (Freshdesk WEB APP, Freshdesk OUTGOING EMAILS, Freshdesk INCOMING EMAILS).