Medication Refill Tracking Discrepancy

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 10:04 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2026 - 13:22 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2026 - 12:55 EDT

Investigating

We are currently investigating two issues affecting medication refill logic:

Refill Quantity Reduction: Processing a single refill updates and reduces the refill counts for all medication refills with the same RX number, rather than tracking each individual deduction independently.

Invalid Refill Availability: If a medication status is set to Refilled, it incorrectly retains the "Refill RX" option in the actions menu (three dots)
Posted Jun 10, 2026 - 13:46 EDT
This incident affected: Vetspire (Web App) (Vetspire UI).