Intermittent Performance Issues

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved; however, we will continue to monitor the system to ensure stability.
Posted May 27, 2026 - 09:01 EDT

Update

We are continuing to monitor the system to ensure stability.
Posted May 27, 2026 - 07:41 EDT

Monitoring

We were experiencing intermittent system performance issues that may have caused some users to be unexpectedly logged out. Our engineering team has identified and mitigated the issue. We are continuing to monitor the system to ensure stability.
Posted May 26, 2026 - 10:22 EDT