3rd party outage- Idexx Outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 18:25 EDT

Monitoring

Idexx has completed a full analysis of potential affected customers and have confirmed that all of them have had the fix applied. Their team has set up a new monitor to be alerted if any additional issues arise, and will continue to actively monitor for at least the next 24 hours
Posted Mar 29, 2025 - 08:22 EDT

Identified

Idexx is currently experiencing an outage that is affecting multiple PIMS including Vetspire. This outage is affecting the ability to order in house and reference labs.

You can reach out to Idexx for more information or follow their status page at https://status.idexxsoftware.com/
Posted Mar 28, 2025 - 17:29 EDT
This incident affected: Third-Party Integrations (Labs) (IDEXX VetConnectPlus & In-House Labs).