Stripe Outage
Incident Report for Vetspire
Resolved
Stripe has resolved the Outage
Posted Apr 29, 2022 - 14:19 PDT
Update
This is a Stripe outage and not related to Vetspire. Please see their status page.
https://status.stripe.com/
Posted Apr 29, 2022 - 14:04 PDT
Investigating
Posted Apr 29, 2022 - 13:54 PDT