Vetspire Traffic

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 11:37 EDT

Monitoring

A fix has been implemented, and performance has returned to normal.
Posted Jun 02, 2026 - 07:00 EDT

Identified

Vetspire has been experiencing increased latency due to higher than normal traffic. The development team will be making some adjustments and will be monitoring them overnight.
Posted Jun 01, 2026 - 16:28 EDT