Vetspire is slow or not loading. Lot's of SAD DOG
Incident Report for Vetspire
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 11:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2022 - 10:53 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 14, 2022 - 10:39 PDT
Investigating
We are currently investigating this issue.
Posted Mar 14, 2022 - 10:29 PDT
This incident affected: Vetspire API and Vetspire Web UI.