Medication Label: Cursor Lag Detected in Instruction Field

Incident Report for Vetspire Status Page

Resolved

We implemented a fix for the issue raised yesterday regarding prescription labels.
Posted Nov 20, 2025 - 07:07 EST

Monitoring

We have implemented a fix for the issue raised earlier today, and will continue to monitor.
Posted Nov 19, 2025 - 16:58 EST

Identified

We have identified the cause of this issue and are working to implement a fix.
Posted Nov 19, 2025 - 11:34 EST

Investigating

We are investigating reports of limited or unavailable access to the listed Vetspire feature(s).
Posted Nov 19, 2025 - 09:57 EST
This incident affected: Vetspire (Web App) (Medication Label).