Idexx Outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Sep 25, 2024 - 14:49 EDT

Update

Idexx is experiencing an outage and they are investigating
Posted Sep 25, 2024 - 12:29 EDT

Investigating

Login Errors in VetConnect Plus
Posted Sep 25, 2024 - 12:28 EDT
This incident affected: Third-Party Integrations (Labs) (IDEXX VetConnectPlus & In-House Labs).