Vetspire Support Chat is experiencing a minor outage. Vetspire uses a third-party integration through Fresh Chat.
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 18:18 EST
Investigating
Vetspire Support Chat is experiencing a minor outage. Vetspire uses a third-party integration through Fresh Chat. Please be patient with us while we wait for them to resolve the issue.
Posted Jan 31, 2023 - 13:45 EST
This incident affected: Vetspire Support - Using Third-Party Integrations (Vetspire Support Chat - Fresh Chat).