SEV-2 Historical Reminders not populating

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Dec 09, 2024 - 08:00 EST

Investigating

We are aware of an issue with historical reminders not populating in the patient chart. We are investigating this issue.
Posted Dec 06, 2024 - 14:09 EST
This incident affected: Vetspire UI (Web APP).