Unable to accept cash payments with change with round down feature enabled

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 12:30 EDT

Identified

We have identified the cause of this issue and are working to implement a fix.
Posted Jul 16, 2026 - 07:04 EDT

Investigating

Currently Investigating: Error message appears when taking a cash payment when "rounding on cash invoices" is enabled.
Posted Jul 15, 2026 - 16:02 EDT
This incident affected: Vetspire (Web App) (Billing).