SEV-2 Declined Immunization showing as a reminder in Patient Reminder Section

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Dec 13, 2024 - 08:22 EST

Update

We are continuing to investigate this issue.
Posted Dec 11, 2024 - 12:41 EST

Investigating

We are currently investigating this issue.
Posted Dec 11, 2024 - 12:39 EST
This incident affected: Vetspire UI (Web APP).