Google widespread service disruption

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:34 EDT

Identified

Google is currently facing a widespread service disruption. Because Vetspire relies on Google Cloud for several critical functions—especially those involving downloading, uploading, and PDF handling—you may notice interruptions or delays in these areas across the platform.
Posted Jun 12, 2025 - 16:01 EDT

Investigating

Google is currently facing a widespread service disruption. Because Vetspire relies on Google Cloud for several critical functions—especially those involving downloading, uploading, and PDF handling—you may notice interruptions or delays in these areas across the platform.

You can check their status page at https://status.cloud.google.com/ for more information.
Posted Jun 12, 2025 - 14:36 EDT
This incident affected: Google (Google Cloud Platform Google Compute Engine).