Unable to Close Hospital Chat and Navigate to Another Page

Incident Report for Vetspire Status Page

Identified

We believe we have identified the root cause of the issue. While we work on a permanent fix, affected users can bypass the frozen chat modal by manually updating their browser URL:

Current URL: vetspire.com/schedule?view=day&openNav=Chat

Updated URL: vetspire.com/schedule?view=day (simply remove &openNav=Chat from the end of the address bar)

We are continuing to collaborate with impacted users to verify the solution and will provide another update as we progress toward a permanent resolution.
Posted Jun 09, 2026 - 18:13 EDT

Investigating

We are currently investigating an issue where for some users the hospital chat feature becomes frozen or locked open on the screen.
Posted Jun 09, 2026 - 15:15 EDT