Unable to save changes on Packages

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Nov 21, 2024 - 08:04 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 21, 2024 - 08:04 EST

Monitoring

A fix has been implemented and we are monitoring the situation
Posted Nov 20, 2024 - 12:02 EST

Investigating

We are investigating an issue where changes made to packages are not reflecting as being saved.
Posted Nov 19, 2024 - 13:12 EST
This incident affected: Vetspire UI (Web APP).