We are investigating a possible Vetspire/Antech integration issue.

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 10:38 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2025 - 10:33 EDT

Investigating

We are currently investigating this issue.
Posted Mar 17, 2025 - 10:28 EDT
This incident affected: Third-Party Integrations (Labs) (ANTECH).