Idexx WebPACS integration now requiring a test to be selected/inputted where previously not required

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 14:55 EDT

Monitoring

We have released a fix for this issue and are continuing to closely monitor performance of Vetspire features.
Posted Aug 19, 2026 - 12:26 EDT

Investigating

We are currently investigating an issue with the IDEXX WebPACS integration, ordering imaging via the integration now unexpectedly requires a specific test to be selected or entered before proceeding. Our engineering team is actively looking into the cause to restore standard functionality. We will provide updates as soon as more information becomes available.
Posted Aug 19, 2026 - 10:12 EDT