Google Cloud AI Temporary System Outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 15:16 EST

Monitoring

AI System performance has been improving, and we have reprocessed all failed Scribe jobs. Users can retrieve their recordings and review their clinical notes. We are continuing to monitor the situation to ensure it is fully resolved.
Posted Dec 04, 2025 - 12:55 EST

Identified

Google Cloud Platform, which powers Vetspire AI Scribe, is currently experiencing degraded performance.
We will be re-running the failed jobs so that recordings can be accessed later in the day.
We will update this page as more information becomes available from Google.
Posted Dec 04, 2025 - 12:15 EST
This incident affected: Vetspire AI.