[SEV-2] Idexx lab orders failing for `other` breeds

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 15:20 EDT

Monitoring

The fix has been deployed, and we are monitoring.
Posted Apr 11, 2025 - 10:03 EDT

Update

A fix was deployed, and we are currently in the testing phase.
Posted Apr 11, 2025 - 07:29 EDT

Identified

The issue has been identified and a fix is being worked on.
Posted Apr 10, 2025 - 19:23 EDT

Investigating

We are working on an issue with Idexx labs failing to order due to Breed status. Current workaround is to Toggle on "Is mixed Breed?: Yes > then reorder the lab.
Posted Apr 10, 2025 - 13:13 EDT
This incident affected: Vetspire UI (Web APP).