3rd Party Outage - Idexx IHD and Reference lab ordering outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 07:42 EDT

Investigating

Idexx is currently experiencing an outage that is affecting multiple PIMS including Vetspire.

You can follow their status page at https://status.idexxsoftware.com/ for any updates
Posted Apr 02, 2025 - 15:42 EDT
This incident affected: Third-Party Integrations (Labs) (IDEXX VetConnectPlus & In-House Labs).