Expiration Dates are not printing on RX label

Incident Report for Vetspire Status Page

Monitoring

We have released a fix for this issue and are continuing to closely monitor.
Posted May 22, 2026 - 09:40 EDT

Identified

We have identified the cause of this issue and are working to implement a fix.
Posted May 20, 2026 - 18:00 EDT

Investigating

We are investigating an issue where Expiration Dates are not displaying on RX labels. Our team is actively working on this issue.
Posted May 20, 2026 - 14:04 EDT
This incident affects: Vetspire (Web App) (Medication Label).