Schedule Display Issue

Incident Report for Vetspire Status Page

Resolved

A fix has been released for the schedule misalignment issue, and schedule functionality has returned to normal. This is now resolved.
Posted Jun 03, 2026 - 17:38 EDT

Investigating

We are actively investigating an issue where scheduled times are displaying misaligned on the UI. Please note that this is purely a display issue and not a loss of functionality.
Posted Jun 03, 2026 - 09:32 EDT
This incident affected: Vetspire (Web App) (Scheduling).