Idexx Outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 18:03 EDT

Investigating

Idexx is currently experiencing an outage affecting several PIMS including Vetspire. This outage affects the ability to order in house and reference diagnostics.

You can follow their status page for updates at https://status.idexxsoftware.com/

Idexx has implemented a fix and
Posted Sep 16, 2026 - 17:06 EDT
This incident affected: Labs (Third-Party Integrations) (IDEXX VetConnectPlus & In-House Labs).