AI Scribe Issue

Incident Report for Vetspire Status Page

Resolved

A fix has been deployed; we are monitoring closely to ensure full recovery.
Posted Feb 20, 2026 - 14:12 EST

Investigating

We are currently investigating an issue with AI Scribe.
Posted Feb 20, 2026 - 13:41 EST
This incident affected: Vetspire AI.