IDEXX IHD and Reference Lab Partial Outage

Incident Report for Vetspire Status Page

Update

IDEXX has reported that a fix has been implemented, and they are continuing to monitor the results.
Posted Mar 30, 2026 - 21:09 EDT

Monitoring

IDEXX is reporting that a fix has been implemented and they are monitoring the results.
Posted Mar 30, 2026 - 16:13 EDT

Identified

IDEXX is currently experiencing an outage that is affecting several PIMS, including Vetspire. Please contact IDEXX for more information
Posted Mar 30, 2026 - 11:43 EDT
This incident affects: Labs (Third-Party Integrations) (IDEXX VetConnectPlus & In-House Labs).