SEV-2 Appointments and Event Blocks showing in half the column on the schedule
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 09:47 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 31, 2024 - 11:15 EDT
Investigating
We are currently investigating this issue.
Posted May 30, 2024 - 11:15 EDT
This incident affected: Vetspire UI (Web APP) and Vetspire API.