Antech - Third Party Outage

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:35 EST

Investigating

Antech is currently experiencing an outage that is affecting several PIMS, including Vetspire. Please contact Antech directly for further details.
Posted Nov 18, 2025 - 08:51 EST
This incident affected: Labs (Third-Party Integrations) (Antech).