Fresh Chat, the service Vetspire Support uses, is experiencing an issue with chats
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved. Chats are operational.
Posted Apr 16, 2024 - 12:18 EDT
Investigating
We are working with Fresh Services to understand the cause of the issue. Please know as soon as the issue is fixed we respond to your chats.
Posted Apr 16, 2024 - 10:11 EDT
This incident affected: Vetspire Support - Using Third-Party Integrations (Vetspire Support Chat - Fresh Chat).