Errors and Limited Access

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 11:57 EDT

Monitoring

We have released a fix for this issue and are continuing to closely monitor performance of Vetspire features. We will update this page when the issue is resolved.
Posted Apr 07, 2026 - 11:08 EDT

Update

We have implemented a fix to mitigate the impact and are currently seeing a significant reduction in error rates. We are remaining in an investigating state as we monitor the environment and continue to work toward a full resolution. We will provide further updates as we confirm complete stability.
Posted Apr 07, 2026 - 10:55 EDT

Update

We are continuing to investigate. We understand this impacts your workflow and are working to restore full functionality as quickly as possible. We will provide another update as soon as more information becomes available.
Posted Apr 07, 2026 - 10:45 EDT

Investigating

We are investigating reports of limited or unavailable access to the listed Vetspire feature(s). We will update this page once we identify the full impact of this issue.
Posted Apr 07, 2026 - 10:19 EDT
This incident affected: Vetspire (Web App) (Vetspire UI, Reporting, Scheduling).