IDEXX Ordering Delay

Incident Report for Vetspire Status Page

Resolved

This incident has been resolved.
Posted Oct 21, 2024 - 19:43 EDT

Investigating

Idexx is experiencing an outage that is affecting mutliple PIMS including Vetspire.

IHD Ordering Delay

Investigating - You may experience a delay when submitting an IDEXX In House Diagnostic (IHD) Order within your Practice Information Management Software. Our team is investigating the issue.

As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX In House Diagnostics and for any inconvenience this may cause.

More information can be found at https://status.idexxsoftware.com/
Posted Oct 21, 2024 - 13:33 EDT
This incident affected: Third-Party Integrations (Labs) (IDEXX VetConnectPlus & In-House Labs).