Currently Vetspire UI is not allowing ordering Idexx Labs
Incident Report for Vetspire Status Page
Resolved
This is now resolved for all Idexx in-house and reference!!

Please know that you may have orphaned labs. We apologize for the inconvenience.
Posted Jul 14, 2022 - 19:19 EDT
Update
This is now resolved for all Idexx in-house and reference!!

Please know that you may have orphaned labs. We apologize for the inconvenience.
Posted Jul 14, 2022 - 19:18 EDT
Update
Idexx reference labs: Is now resolved.
Idexx: In-House, we are still working on
Posted Jul 14, 2022 - 16:50 EDT
Update
Idexx reference labs: Is now resolved.
Idexx: In-House, we are still working on.
Posted Jul 14, 2022 - 16:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 14, 2022 - 11:42 EDT
Investigating
We are currently investigating this issue.
Posted Jul 14, 2022 - 09:20 EDT
This incident affected: Vetspire UI (Web APP) and Third-Party Integrations (Labs) (IDEXX VetConnectPlus & In-House Labs).