Products are Not Able to Ordered
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 15:48 EDT
Monitoring
A fix was found and implemented. We are currently monitoring the fix. Please refresh your page. If you are still experiencing issues, please let us know in the chat.
Posted Sep 28, 2022 - 15:39 EDT
Investigating
Vetspire is aware that all products are not viewable in the UI. We are investing now and will update ASAP.
Posted Sep 28, 2022 - 15:29 EDT
This incident affected: Vetspire UI (Web APP).