Vetspire is not Communicating with Cubex
Incident Report for Vetspire
Resolved
We are continuing to investigate this issue.
Posted Mar 17, 2022 - 01:15 PDT
Update
We are continuing to investigate this issue.
Posted Mar 17, 2022 - 01:00 PDT
Investigating
We are currently investigating this issue.
Posted Mar 16, 2022 - 17:28 PDT
This incident affected: Third-Party Integrations (Cubex).