IDEXX VetConnect Plus is experiencing a partial outage
Incident Report for Vetspire Status Page
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 01:10 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 03, 2023 - 01:10 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 02, 2023 - 21:10 EST
Investigating
The IDEXX VetConnect Plus website has posted about scheduled maintenance beginning Feb 2nd, 6pm EST. We are aware that this is impacting In House labs and will update this page as necessary
Posted Feb 02, 2023 - 20:38 EST
This incident affected: Third-Party Integrations (Labs) (IDEXX VetConnectPlus & In-House Labs).